Ubuntu HowTo: ubuntu 16.04 apt-get update error: File not found – /var/cuda-repo-8-0-rc/Packages

Original Source Link

When I execute sudo apt-get update in Terminal, this error message appears. Can anyone help me?

Get:1 file:/var/cuda-repo-8-0-rc  InRelease
Ign:1 file:/var/cuda-repo-8-0-rc  InRelease
Get:2 file:/var/cuda-repo-8-0-rc  Release
Ign:2 file:/var/cuda-repo-8-0-rc  Release
Get:3 file:/var/cuda-repo-8-0-rc  Packages
Ign:3 file:/var/cuda-repo-8-0-rc  Packages
Get:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Ign:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Get:5 file:/var/cuda-repo-8-0-rc  Translation-en
Ign:5 file:/var/cuda-repo-8-0-rc  Translation-en
Get:3 file:/var/cuda-repo-8-0-rc  Packages
Ign:3 file:/var/cuda-repo-8-0-rc  Packages
Get:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Ign:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Get:5 file:/var/cuda-repo-8-0-rc  Translation-en
Ign:5 file:/var/cuda-repo-8-0-rc  Translation-en
Get:3 file:/var/cuda-repo-8-0-rc  Packages
Ign:3 file:/var/cuda-repo-8-0-rc  Packages
Get:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Ign:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Get:5 file:/var/cuda-repo-8-0-rc  Translation-en
Ign:5 file:/var/cuda-repo-8-0-rc  Translation-en
Get:3 file:/var/cuda-repo-8-0-rc  Packages
Ign:3 file:/var/cuda-repo-8-0-rc  Packages
Get:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Ign:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Get:5 file:/var/cuda-repo-8-0-rc  Translation-en
Ign:5 file:/var/cuda-repo-8-0-rc  Translation-en
Get:3 file:/var/cuda-repo-8-0-rc  Packages
Ign:3 file:/var/cuda-repo-8-0-rc  Packages
Get:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Ign:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Get:5 file:/var/cuda-repo-8-0-rc  Translation-en
Ign:5 file:/var/cuda-repo-8-0-rc  Translation-en
Get:3 file:/var/cuda-repo-8-0-rc  Packages
Err:3 file:/var/cuda-repo-8-0-rc  Packages
  File not found - /var/cuda-repo-8-0-rc/Packages (2: No such file or directory)
Get:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Ign:4 file:/var/cuda-repo-8-0-rc  Translation-en_US
Get:6 http://security.ubuntu.com/ubuntu xenial-security InRelease [94.5 kB]                                                                                                                        
Hit:7 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease                          
Hit:8 http://cn.archive.ubuntu.com/ubuntu xenial InRelease                                                 
Hit:9 http://storage.googleapis.com/bazel-apt stable InRelease                                            
Hit:11 http://cn.archive.ubuntu.com/ubuntu xenial-updates InRelease                  
Get:10 https://apt.dockerproject.org/repo ubuntu-xenial InRelease [20.6 kB]           
Hit:12 http://cn.archive.ubuntu.com/ubuntu xenial-backports InRelease                   
Get:13 https://apt.dockerproject.org/repo ubuntu-xenial/main amd64 Packages [1,719 B]
Hit:14 https://apt.dockerproject.org/repo ubuntu-xenial/main i386 Packages
Ign:14 https://apt.dockerproject.org/repo ubuntu-xenial/main i386 Packages
Hit:14 https://apt.dockerproject.org/repo ubuntu-xenial/main i386 Packages
Ign:14 https://apt.dockerproject.org/repo ubuntu-xenial/main i386 Packages
Hit:14 https://apt.dockerproject.org/repo ubuntu-xenial/main i386 Packages
Err:14 https://apt.dockerproject.org/repo ubuntu-xenial/main i386 Packages
  Empty files can't be valid archives
Fetched 117 kB in 3s (36.8 kB/s)
Reading package lists... Done
W: The repository 'file:/var/cuda-repo-8-0-rc  Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: http://storage.googleapis.com/bazel-apt/dists/stable/InRelease: Signature by key 71A1D0EFCFEB6281FD0437C93D5919B448457EE0 uses weak digest algorithm (SHA1)
N: Skipping acquire of configured file 'jdk1.8/binary-i386/Packages' as repository 'http://storage.googleapis.com/bazel-apt stable InRelease' doesn't support architecture 'i386'
E: Failed to fetch file:/var/cuda-repo-8-0-rc/Packages  File not found - /var/cuda-repo-8-0-rc/Packages (2: No such file or directory)
E: Failed to fetch store:/var/lib/apt/lists/partial/apt.dockerproject.org_repo_dists_ubuntu-xenial_main_binary-i386_Packages  Empty files can't be valid archives
E: Some index files failed to download. They have been ignored, or old ones used instead.

I had a simalar issue with “cuda-repo-ubuntu1504-7-5-local_7.5-18_amd64.deb” on Ubuntu 16.04LTS after removing the package with: sudo dpkg -r cuda-repo-ubuntu1504-7-5-local

Solved it with the next command: sudo dpkg –purge cuda-repo-ubuntu1504-7-5-local

Tagged : / / / /

Leave a Reply

Your email address will not be published. Required fields are marked *